home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / acx-0.3.35 / acx-0.3.35.ebuild next >
Text File  |  2006-05-11  |  895b  |  41 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35.ebuild,v 1.2 2006/03/03 03:59:08 tsunam Exp $
  4.  
  5. inherit linux-mod
  6.  
  7. DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
  8.  
  9. HOMEPAGE="http://acx100.sourceforge.net/"
  10. SRC_URI="http://acx100.erley.org/acx-20060215.tar.bz2"
  11.  
  12. LICENSE="GPL-2 as-is"
  13. SLOT="0"
  14. KEYWORDS="~amd64 x86"
  15.  
  16. RDEPEND="net-wireless/wireless-tools
  17.     net-wireless/acx-firmware"
  18.  
  19. S=${WORKDIR}
  20.  
  21. MODULE_NAMES="acx(net:${S})"
  22. CONFIG_CHECK="NET_RADIO FW_LOADER"
  23. BUILD_TARGETS="modules"
  24.  
  25. pkg_setup() {
  26.     linux-mod_pkg_setup
  27.     BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
  28. }
  29.  
  30. src_unpack() {
  31.     unpack ${A}
  32.     chmod ug+w . -R
  33.     sed -i 's:usr/share/acx:lib/firmware:' common.c || die "sed failed"
  34. }
  35.  
  36. src_install() {
  37.     linux-mod_src_install
  38.  
  39.     dodoc README
  40. }
  41.